XTypo and Joomla 4

Sry - can't make it work...
I also uninstalled exisitng XTypo PRO, logged out, closed browser, reopened, cleared cache, re-installed XTypo PRO, newly downloaded version - but no luck...

Would it be interesting that
Package and button is v. 1.0.2 (2023.11.07),
but content is v. 1.00 (2023.09.21)
?
7 months 2 weeks ago #55 by Jensen

Please Log in or Create an account to join the conversation.

  • Posted by TemplatePlazza (5215) Offline
My apologies, I uploaded the incorrect file. I have reuploaded it. Please redownload and update to version 1.1.0. I have retested it, and it should be working properly now
www.dropbox.com/scl/fi/wfbxt8hg51uvfb4pk...5wpg65f8f62dt8&raw=1

Would it be interesting that
Package and button is v. 1.0.2 (2023.11.07),
but content is v. 1.00 (2023.09.21)
?

Yes, the update is only affecting the Button plugin. The Content plugin is working fine.
7 months 2 weeks ago - 7 months 2 weeks ago #56 by TemplatePlazza
Last edit: 7 months 2 weeks ago by TemplatePlazza.

Please Log in or Create an account to join the conversation.

Hi Team, interesting plugin - to make a try, i downloadad and installed the standard version of XTypo ... installed, activated the plugins.
But if i want to work with it, the modal window opens - but i only get the field, for entering youtube id. Nothing else. No other blocks ...

What is the reason? Bug?

Joomla 4.4.1
PHP 8.1 on WebServer

Thank you for assistance - if all would work fine,  i purchase the pro ... but if a test failed ..
 
6 months 3 weeks ago - 6 months 3 weeks ago #57 by FDE683
Last edit: 6 months 3 weeks ago by FDE683.

Please Log in or Create an account to join the conversation.

  • Posted by TemplatePlazza (5215) Offline
Hi, have you read the documentation before? You need to enter the CSS file path and remove the iframe from the prohibited element settings. Have you done that?
6 months 3 weeks ago #58 by TemplatePlazza
Attachments:

Please Log in or Create an account to join the conversation.

Sorry, i did not. A also use mastertools and made all changes - now it is working .. so far.

But first, i did not see the result inside the editor. It looks different to you screenshots / videos. Treid all view-options from the editor ...
See screnshots.
1. is editor ... no difference in case of just typing this text (exept that the word "button" is a link.
2 in frontend it is fine.

What else do i have to set / ceck, please?

Questions:
is there a central area, where to modify the css-classes for the different options (buttons colours, forms ...) - in the admin beckend / component?
Or is this a manual job for developers in css files? (which ones / where)  What could be an idea for future versions?

Additional some thoughts - for better users experiece:
1. in case of typing the link in the buttons field, it did not ask for "https" ... like joomla do this if i set a link in the editor (many customers make this fail-links as the https is not added.

Thank you
6 months 3 weeks ago #59 by FDE683
Attachments:

Please Log in or Create an account to join the conversation.

  • Posted by TemplatePlazza (5215) Offline

But first, i did not see the result inside the editor. It looks different to you screenshots / videos. Treid all view-options from the editor ...
See screnshots.

Strange, could you please provide your website URL for me to check? The url you need to enter in the TinyMCE plugin should be like this : your-domain-name.com/plugins/editors-xtd...editor-xtypo.min.css

is there a central area, where to modify the css-classes for the different options (buttons colours, forms ...) - in the admin beckend / component?
Or is this a manual job for developers in css files? (which ones / where)  What could be an idea for future versions?

To modify the styles of elements, there are several options.

1. You can add them in the CSS adjustments on the content plugin settings page. These changes will be applied to all elements, regardless of where you place them.


2. Or you can also utilize custom in-page code. This will only affect the elements on that specific page. This feature is available in Xtypo Pro. Please see this :


3. Or, in more advance way, you can add your modified style and add kthe css code to your template css file.

1. in case of typing the link in the buttons field, it did not ask for "https" ... like joomla do this if i set a link in the editor (many customers make this fail-links as the https is not added.


I'm unable to replicate this issue. It allows me to type whatever link I want. Please see this video www.dropbox.com/scl/fi/kr83x7w77ca5ldaau...fzn34tycao0wt9&raw=1



 
6 months 3 weeks ago - 6 months 3 weeks ago #60 by TemplatePlazza
Attachments:
Last edit: 6 months 3 weeks ago by TemplatePlazza.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum